Previous Page | Next Page

by antidote at 4:34 PM EDT on July 5, 2016
Oh, amuseplay has always had support for raw files ;P

EDIT:
In VBox make sure you have a full D3D not just basic, and 3D acceleration enabled in the settings, you *should* be able to run it fine after that.

If it still doesn't run, try adding --gl, since GL mostly works in guests once full D3D is enabled, I've been able to successfully run amuseplay in a VM, though this was on Arch, not XP so the details may be different.

EDIT2:

On another note, I've been able to build a 10.10.3 binary that should work fine, I'll upload it here in a few minutes.

edited 4:39 PM EDT July 5, 2016
by Nisto at 4:44 PM EDT on July 5, 2016
Yes, I have everything 3D-related activated and installed (i.e. guest additions) in VirtualBox. They do say D3D support is still experimental though, so... =/
by antidote at 4:55 PM EDT on July 5, 2016
Yeah, it's definitely experimental, however it works pretty well overall.

Also, starerik can you give this build a try?
https://dl.dropboxusercontent.com/u/21757902/amuse-osx-10.10.zip
by Nisto at 5:04 PM EDT on July 5, 2016
Just for clarification, what exactly do you mean by "full D3D not just basic"? I've double checked and specifically have the 3D Acceleration option enabled, and as previously mentioned, the guest additions Direct3D driver installed. Apart from that I don't really see anything else related to D3D. Have I missed anything?

edited 5:05 PM EDT July 5, 2016
by starerik at 5:05 PM EDT on July 5, 2016
Yes, that one booted. But I got a very long error message, which I'll post in the issues section.
by antidote at 5:12 PM EDT on July 5, 2016
@Nisto when you install the driver it'll ask you if you want to install the "Basic" version, click "No"
by starerik at 5:21 PM EDT on July 5, 2016
Nevermind, I switched audio driver and it worked. But the ADSR doesn't quite sound right for Adventures.
by Nisto at 5:36 PM EDT on July 5, 2016
@antidote, yep just went through the guest additions installer again and made sure to install both the basic and the one required for WDDM/Aero (I know I already installed the latter though). The error for the OpenGL interface seems to have changed, but it gave no real progress. I have also tried running it with administrator privileges, but still no luck. Maybe the D3D support is experimental on a hardware level? I'm on a creaky ATI HD 4850 here, so who knows...
by antidote at 6:28 PM EDT on July 5, 2016
That could be it, we require D3D11 minimum, but we can drop that to 10 I think, that's jack's territory.
by jackoalan at 2:59 AM EDT on July 6, 2016
Yea, D3D12 appears to be problematic in certain hardware configurations.. Some aspects of it feel like Windows Vista all over again, with a sizable number of older machines not able to run the new system APIs 100% to MS' spec. Doesn't help that the automatic upgrade doesn't make such distinctions, anyway I digress..

I'm thinking a first-run prompt would be the wisest solution offering the user a selection of backend graphics APIs to use. The selection wouldn't be saved until after the window is spawned and the app hasn't crashed.

I'm especially interested in adopting Vulkan on Windows and possibly making it the first choice if it seems to run well for a wide range of HW. That would provide a way for Win7 users to hop on the command buffer graphics bandwagon too.

EDIT: antidote must not be aware that D3D10 has horrendously unpredictable multithreading behavior; I'm afraid the architecture of our systems forces us to use D3D11 minimum

edited 3:14 AM EDT July 6, 2016

Previous Page | Next Page
Go to Page 0 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22

Search this thread

Show all threads

Reply to this thread:

User Name Tags:

bold: [b]bold[/b]
italics: [i]italics[/i]
emphasis: [em]emphasis[/em]
underline: [u]underline[/u]
small: [small]small[/small]
Link: [url=http://www.google.com]Link[/url]

[img=https://www.hcs64.com/images/mm1.png]
Password
Subject
Message

HCS Forum Index
Halley's Comet Software
forum source